Building a GainClone Chip Amplifier

I've been reading about GainClone chip amplifiers on and off for years. In fact I have a fully-constructed but never powered-up chip amplifier constructed from a TDA2005 integrated circuit. It was destined as a car audio amp but we ended up buying a Pioneer MP3 head unit for the old car early this year.

After some discussion on the Pinoyboats forum, one of the members, Kuya Ton, mentioned the good possibilities of using a GainClone along with Wharfedale Diamond 9.1 or 9.2 bookshelf speakers.

The GainClone is an "open-source" rebuild of the famous $3500 GainCard from 47Labs. Kind of mind-boggling that audio fanatics will fork over $3500 for an amplifier constructed from a $5 power op amp.

In any case, I ordered some parts from RS Components Philippines (they have a minimum order of five pieces for the NS LM1875T, which I split with Kuya Ton).





We ordered the LM1875T chips from RS Components, even though they are much more expensive (PHP 180 each, or about $4) than at local Alexan Commercial in Megamall, because there's lots of fake IC's floating around, and the theory was that buying from RS Components would ensure getting the real deal.



Audiophiles also claim that using an ultra-fast recovery (35-nanosecond) soft diode results in improved sound! the usual diode used is the MUR860 from On Semiconductor, but RS didn't have any of those. They did have the MUR1520, which is a higher-power version but also TO-220, for PHP 49 each (about $1) in quantities of 25.

I had some old TO-220 heat sinks from my car amp project (these sinks were too small for the Thermotab packaged TDA2005 chip).



This heat sink is very similar to the Aavid Thermalloy Part No. BW/B/38 (7.2 C/W) but is larger in all dimensions. I guesstimated it to be good for about 6 C/W capacity. Since I have no mica insulator between the heat sink and LM1875T, it should be good for around 10W power dissipation. The thermal shutdown protection of the LM1875 should take care of the rest. 10W is pretty loud with decent speakers.

This is the schematic diagram of John Bell's Non-Inverting GainClone (NIGC):



Apparently in 1999-2002, the Non-Inverting GainClone was all the rage; then in 2002 everyone switched to Thorsten Loesch's inverting GainClone and its variants. But nowadays, the Non-Inverting version is back in vogue. One key benefit of the NIGC is that the (long) input signal wire is kept safely off from the feedback loop.

I used 1k and 47k for the feedback network instead of 680R and 22k because these resistors were what I had in my parts box. Also I used 330R on the input instead of 220R for the same reason. Similarly, i dropped the Zobel network on the output.

Initially I didn't have the 27k resistance to ground on the non-inverting input, because that's what Mark Houston's Nanoo design uses. However this didn't work for me, resulting in idle output voltage at Vcc (which needless to say would be horrible for the speakers). After a call to Kuya Ton and checking on Google, I verified that the pull-down resistor is needed and added it.

This brought down quiescent voltage to 40mV on channel 1, and 60mV on channel 2, as measured by my cheap Chinese digital multimeter.



My version has a much higher gain (nominal 47 or 33dB) as compared to 30dB for John Bell's version. I also changed the input resistors and got rid of the Zobel network on the output. Since standard line-level is 0.7V peak to peak, with a gain of 47 that would give 33V peak to peak, which with my 12V supplies would result in lots of clipping. Solution? don't crank up the volume on the signal source.

Here's my initial construction step:



Twisted the resistor leads onto the legs of the LM1875T so that the joints are mechanically secure. The feedback resistor is the large one between pins 2 and 4.

Both amplifiers, fully constructed. I made a major mistake - single star ground for both the power circuit and the small-signal circuit. I also ran out of hookup wire so I used some Cat-5 Ethernet cable, stripped out the little wires inside it, and used those. They are Gauge 24 so should be good for 3 amps of current.



I think the extensive use of recycled Cat-5 cable was a bad idea: in addition to the single ground, the small-signal input cable is just ordinary twisted pair, not shielded coax. This is the first thing I'll fix, as the amplifier hums when there's no signal.

Another, close-up view. The 27k input resistor is completely covered with heat-shrink tubing. I used a lot of heat-shrink tubing, as I'm paranoid. When everything's nice and sounds good, I will encapsulate the IC legs and solder joints with hot-melt glue to fix it in place.



Following Kuya Ton's advice, I used a couple of halogen transformers (used for powering 12V track lighting, PHP 300 or about $7 each) as the power source. Not such a great deal, a 12-0-12 VAC, 2.5A E-I core transformer from Alexan goes for about PHP 250, but looks much worse, and the halogen transformers are 4A each.

It's possible to wire the secondaries of the two transformers in series to get the effect of a center-tapped transformer, but one must measure the output voltage to make sure the secondaries are "in phase." Otherwise the net output voltage will be zero! also, the primaries must be wired in the same way, swapping the wires will cause the secondary voltages to cancel out.



Here are four MUR1520's in a standard full-wave rectifier bridge. Looks much more impressive than the garden-variety 1N4001 or 1N5401 everybody else uses! I mounted them on a small broken-off bit of perforated board from the TDA2005 project.



Here's the full setup. I cannibalized a couple of Kenwood 4-ohm speakers (actually they are the rear speakers from the unfortunate Mazda 626).



The speakers are in pretty bad shape (dust cap has fallen off of one, whizzer cones cracked and fell off, and the cones have gotten warped because of stuff that got placed on top of them).

I drove the amplifiers off my Toshiba notebook, and from our television set. Sound is detailed but lacks any sort of body, understandable because the speakers have no enclosure whatsoever. Also these are 4-ohm speakers for car audio, and thus not really suitable for the GainClone.

But at least I know they work. There's an objectionable amount of hum when no signal is present, about as much as our Altec Lansing ACS45 systems. Pretty bad for what's supposed to be a somewhat mid-fi system. I suspect it's the single star ground, the not-beefy enough grounding wires, and the ordinary twisted-pair wire on the small-signal input.

Also, the small heat sinks get warm. Not hot, but definitely warm. And this was at low volume. I will need larger ones. I'll fix all of the outstanding issues and see if the sound improves. If it does, I'll try to negotiate a purchase of those Wharfedales.